FrameworkKeyboardShortcuts Interface
keyboardShortcuts interface
Methods
Name | Description | |
---|---|---|
closeMenu(): void | Closes the Keyboard Shortcuts menu | |
displayMenu(): void | Displays the Keyboard Shortcuts menu at the cursor | |
getShortcut(keyMapKey: string): undefined | FrameworkKeyboardShortcut | Returns a Keyboard Shortcut from the managed lists | |
loadShortcut(shortcutProps: KeyboardShortcutProps): void | Loads a Keyboard Shortcut into the managed list | |
loadShortcuts(shortcutList: KeyboardShortcutProps[]): void | Loads Keyboard Shortcuts into the managed list | |
processKey(keyboardKey: string, isAltKeyPressed?: boolean, isCtrlKeyPressed?: boolean, isShiftKeyPressed?: boolean): boolean | Processes a keystroke and invokes a matching Keyboard Shortcut | |
setFocusToHome(): void | Sets focus to Home |
Properties
Name | Type | Description | |
---|---|---|---|
cursorX Readonly | number | Returns the cursor X position, which is mouseEvent.pageX. | |
cursorY Readonly | number | Returns the cursor Y position, which is mouseEvent.pageY. | |
isFocusOnHome Readonly | boolean | Determines if focus is set to Home | |
shortcutContainer Readonly | FrameworkKeyboardShortcutContainer | Returns the managed list of Keyboard Shortcuts |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.