popoutWidget Method

Create a new popout/child window that contains the widget specified by its Id.

popoutWidget(widgetId: string, position?: Readonly<WritableXAndY>, size?: SizeProps): void

Parameter Type Description
widgetId string case sensitive Widget Id
position Readonly<WritableXAndY> Position of top left corner of floating panel in pixels. If undefined {x:0, y:0} is used.
size SizeProps defines the width and height of the floating panel. If undefined and widget has been floated before
the previous size is used, else {height:800, width:600} is used.

Returns - void

Defined in

Last Updated: 14 November, 2024