FrameworkDialog Interface
Manages dialog access
Methods
Name | Description | |
---|---|---|
close(dialog?: React.ReactNode): void | Close a modal dialog | |
open(dialog: React.ReactNode, id?: string, parentDocument?: Document): void | Open a modal dialog | |
update(): void | Update the dialogs |
Properties
Name | Type | Description | |
---|---|---|---|
active Readonly | React.ReactNode | Get the active modal dialog | |
count Readonly | number | Get the count of modal dialogs | |
dialogs Readonly | DialogInfo[] | Get the array of modal dialogs |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.