IModelViewportControlOptions Interface
Deprecated in 4.16.0. Used in a deprecated class IModelViewportControl.
IModelViewportControl options. These options are set in the applicationData property of the ContentProps.
Properties
Name | Type | Description | |
---|---|---|---|
alwaysUseSuppliedViewState | boolean | undefined | Optional property to always use the supplied viewState property instead of using viewport.view when set |
|
bgColor | string | undefined | Optional background color which may be used if viewState and iModelConnection are undefined | |
deferNodeInitialization | boolean | undefined | Optional property to defer reactNode initialization until first reactNode property is needed. | |
featureOptions | [key: string]: any | undefined | Map of options that can be used to enable/disable features within the view | |
iModelConnection | IModelConnection | () => IModelConnection | IModelConnection of data in Viewport | |
supplyViewOverlay | (_viewport: ScreenViewport) => React.ReactNode | undefined | Optional property to supply custom view overlay. | |
viewState | ViewStateProp | undefined | ViewState or a function to return a ViewState |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.