FloatingViewportContentProps Interface
Deprecated in 4.16.0. Props of deprecated component FloatingViewportContent.
Properties
Name | Type | Description | |
---|---|---|---|
contentId | string | viewport/content control uniqueId | |
initialViewState | ViewStateProp | The initial view state used to create the viewport, or a function that returns it (will refresh when the function changes) | |
onContextMenu | (e: React.MouseEvent<Element, MouseEvent>) => boolean | undefined | callback used to construct context menu when user right-clicks on canvas/viewport | |
viewportRef | React.Ref<ScreenViewport> | undefined | Function to get a reference to the ScreenViewport |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.