open Method
Open a new child window.
open(childWindowId: string, title: string, content: React.ReactNode, location: ChildWindowLocationProps, useDefaultPopoutUrl?: boolean): boolean
@returns true if the window is opened successfully.
Parameter | Type | Description |
---|---|---|
childWindowId | string | Id to assign to the newly created window. |
title | string | Title to display on the window. |
content | React.ReactNode | ReactNode to be rendered in the window. |
location | ChildWindowLocationProps | Position and size information |
useDefaultPopoutUrl | boolean | use "/iTwinPopup.html" as the window Url, "" otherwise. |
Returns - boolean
true if the window is opened successfully.
Defined in
Last Updated: 17 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.