showLengthEditor Method
Deprecated in 4.11.0. Use ($("length")$refLinkSource=appui-react/ui/appui-react/src/appui-react/uiadmin/FrameworkUiAdmin.tsx@278).
Show an input editor for a length value at a particular location.
showLengthEditor(initialValue: number, location: Readonly<WritableXAndY>, onCommit: OnNumberCommitFunc, onCancel: OnCancelFunc, htmlElement?: HTMLElement): boolean
@returns true if the editor was displayed, false if the editor could not be displayed.
Parameter | Type | Description |
---|---|---|
initialValue | number | Value initially displayed in the editor. |
location | Readonly<WritableXAndY> | Location of the editor, relative to the origin of htmlElement or the window. |
onCommit | OnNumberCommitFunc | Function called when the OK button or the Enter key is pressed. |
onCancel | OnCancelFunc | Function called when the Cancel button or the Escape key is pressed. |
htmlElement | HTMLElement | The HTMLElement that anchors the context menu. If undefined, the location is relative to the overall window. |
Returns - boolean
true if the editor was displayed, false if the editor could not be displayed.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.