showInputEditor Method
Show an input editor for a primitive value at a particular location.
showInputEditor(initialValue: Primitives.Value, propertyDescription: PropertyDescription, location: Readonly<WritableXAndY>, onCommit: OnValueCommitFunc, onCancel: OnCancelFunc, htmlElement?: HTMLElement): boolean
@returns true if the editor was displayed, false if the editor could not be displayed.
Parameter | Type | Description |
---|---|---|
initialValue | Primitives.Value | Value initially displayed in the editor. |
propertyDescription | PropertyDescription | Description of the primitive value property |
location | Readonly<WritableXAndY> | Location of the editor, relative to the origin of htmlElement or the window. |
onCommit | OnValueCommitFunc | Function called when the OK button or the Enter key is pressed. |
onCancel | OnCancelFunc | Function called when the Cancel button or the Escape key is pressed. |
htmlElement | HTMLElement | The HTMLElement that anchors the context menu. If undefined, the location is relative to the overall window. |
Returns - boolean
true if the editor was displayed, false if the editor could not be displayed.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.