CalculatorProps Interface
Extends
Properties
Name | Type | Description | |
---|---|---|---|
initialValue | number | undefined | Initial value | |
onCancel | OnCancelFunc | undefined | A function to be run when the Cancel button is clicked | |
onOk | OnNumberCommitFunc | undefined | A function to be run when the OK button is clicked | |
resultIcon | React.ReactNode | undefined | Icon to display beside the calculated result |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.