AccuDrawInputFieldProps Interface
Deprecated in 4.17.0. Use React.ComponentProps<typeof AccuDrawInputField>
Properties for AccuDrawInputField component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
field | ItemField | Which AccuDraw field this represents | |
icon | React.ReactNode | undefined | Icon for the input element. | |
iconSpec | IconSpec | undefined | Icon for the input element. | Deprecated |
id | string | id for the input element | |
isLocked | boolean | undefined | Indicates whether field is locked | |
label | string | undefined | label for the input element | |
labelCentered | boolean | undefined | Center justified label | |
labelClassName | string | undefined | Custom CSS class name for the label | |
labelStyle | React.CSSProperties | undefined | Custom CSS Style for the label | |
onEnterPressed | () => void | undefined | Listens for |
|
onEscPressed | () => void | undefined | Listens for |
|
onValueChanged | (stringValue: string) => void | Triggered when the content is changed | |
ref | React.Ref<HTMLInputElement> | undefined | Provides ability to return reference to HTMLInputElement | |
valueChangedDelay | number | undefined | Frequency to poll for changes in value, in milliseconds |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.