LayoutHorizontalSplitProps Interface
Deprecated in 4.10.x. Use LayoutHorizontalSplitProps
from @itwin/appui-react
.
Properties for a horizontal layout split When a member is a LayoutFragmentProps, it creates a nested split pane. When a number, it represents an index into a ContentGroup.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bottom | number | LayoutFragmentProps | Bottom layout fragment properties. | |
minSizeBottom | number | undefined | Minimum size of the bottom fragment. | |
minSizeTop | number | undefined | Minimum size of the top fragment. | |
top | number | LayoutFragmentProps | Top layout fragment properties. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
id Inherited | string | LayoutSplitPropsBase | The id used to save the current state of the splitter |
lock Inherited | boolean | undefined | LayoutSplitPropsBase | Used to lock splitter into fixed position. |
percentage Inherited | number | LayoutSplitPropsBase | The percentage of this layout that should be occupied by the top/left fragment by default |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.