GeometryTileTreeReference Interface
Beta
A TileTreeReference that can supply geometry in the form of Polyfaces from Tiles belonging to its TileTree and satisfying the criteria defined by a TileGeometryCollector. Use TileTreeReference.createGeometryTreeReference to obtain a GeometryTileTreeReference from an existing TileTreeReference.
Extends
Methods
Name | Description | |
---|---|---|
collectTileGeometry(collector: TileGeometryCollector): void | Populate TileGeometryCollector.polyfaces with geometry satisfying collector 's criteria. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
_collectTileGeometry(collector: TileGeometryCollector): void Protected | TileTreeReference | A function that can be assigned to TileTreeReference.collectTileGeometry to enable geometry collection for references to tile trees that support geometry collection. |
_createGeometryTreeReference(): undefined | GeometryTileTreeReference Protected | TileTreeReference | Create a tile tree reference equivalent to this one that also supplies an implementation of GeometryTileTreeReference.collectTileGeometry. |
accumulateTransformedRange(range: Range3d, matrix: Matrix4d, frustumPlanes?: FrustumPlanes): void | TileTreeReference | |
addLogoCards(_cards: HTMLTableElement, _vp: ScreenViewport): void | TileTreeReference | Add attribution logo cards for the tile tree source logo cards to the viewport's logo div. |
addToScene(context: SceneContext): void | TileTreeReference | Adds this reference's graphics to the scene. |
collectStatistics(stats: RenderMemory.Statistics): void | TileTreeReference | |
computeTransform(tree: TileTree): Transform Protected | TileTreeReference | Compute a transform from this tile tree reference's coordinate space to the IModelConnection's coordinate space. |
computeWorldContentRange(): Range3d | TileTreeReference | Compute the range of this tile tree's contents in world coordinates. |
createDrawArgs(context: SceneContext): undefined | TileDrawArgs | TileTreeReference | Create context for drawing the tile tree, if it is ready for drawing. |
createGeometryTreeReference(): undefined | GeometryTileTreeReference | TileTreeReference | Obtain a tile tree reference equivalent to this one that also supplies an implementation of GeometryTileTreeReference.collectTileGeometry, or |
decorate(_context: DecorateContext): void | TileTreeReference | Optionally add any decorations specific to this reference. |
discloseTileTrees(trees: DisclosedTileTreeSet): void | TileTreeReference | Disclose all TileTrees use by this reference. |
draw(args: TileDrawArgs): void | TileTreeReference | Adds this reference's graphics to the scene. |
getAnimationTransformNodeId(_tree: TileTree): undefined | number Protected | TileTreeReference | |
getAppearanceProvider(_tree: TileTree): undefined | FeatureAppearanceProvider Protected | TileTreeReference | Return a provider that can supplement the view's symbology overrides. |
getClipVolume(tree: TileTree): undefined | RenderClipVolume Protected | TileTreeReference | Return the clip volume applied to this reference's tile tree, if any. |
getHiddenLineSettings(_tree: TileTree): undefined | Settings Protected | TileTreeReference | Return hidden line settings to replace those defined for the view. |
getLocation(): undefined | Transform | TileTreeReference | Supply transform from this tile tree reference's location to iModel coordinate space. |
getMapFeatureInfo(_hit: HitDetail): Promise<undefined | []> | TileTreeReference | Optionally return a MapLayerFeatureInfo object describing the hit.]. |
getSymbologyOverrides(_tree: TileTree): undefined | FeatureSymbology.Overrides Protected | TileTreeReference | Return overrides that replace any defined for the view. |
getTerrainHeight(_terrainHeights: Range1d): void | TileTreeReference | |
getToolTip(_hit: HitDetail): Promise<undefined | string | HTMLElement> | TileTreeReference | Optionally return a tooltip describing the hit. |
getViewFlagOverrides(tree: TileTree): Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> Protected | TileTreeReference | Supply overrides that should be applied to the ViewState's ViewFlags when drawing this tile tree reference. |
resetTreeOwner(): void | TileTreeReference | Force a new tree owner / tile tree to be created for the current tile tree reference |
unionFitRange(union: Range3d): void | TileTreeReference | Unions this reference's range with the supplied range to help compute a volume in world space for fitting a viewport to its contents. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_isLoadingComplete Accessor ReadOnly | boolean | TileTreeReference | Override if additional asynchronous loading is required after the tile tree is successfully loaded, to indicate when that loading has completed. |
castsShadows Accessor ReadOnly | boolean | TileTreeReference | Return whether the geometry exposed by this tile tree reference should cast shadows on other geometry. |
isGlobal Accessor ReadOnly | boolean | TileTreeReference | Return whether this reference has global coverage. Mapping data is global and some non-primary models such as the OSM building layer have global coverage |
isLoadingComplete Accessor ReadOnly | boolean | TileTreeReference | Return true if the tile tree is fully loaded and ready to draw. The default implementation returns true if the tile tree loading process completed (whether it resulted in success or failure). |
planarclipMaskPriority Accessor ReadOnly | number | TileTreeReference | Return the clip mask priority for this model - models will be clipped by any other viewed model with a higher proirity. BIM models have highest prioirty and are never clipped. |
treeOwner Accessor AbstractReadOnly | TileTreeOwner | TileTreeReference | The owner of the currently-referenced TileTree. Do not store a direct reference to it, because it may change or become disposed at any time. |
Defined in
Last Updated: 20 June, 2023