DisclosedTileTreeSet Class
A set of TileTrees disclosed by a set of objects implementing TileTreeDiscloser, used to collect references to tile trees in use by those objects.
extensions
Implements
- Iterable<TileTree>
Methods
Name | Description | |
---|---|---|
constructor(comparator?: OrderedComparator<TileTree, TileTree>): DisclosedTileTreeSet | Construct a new set. | |
[iterator](): Iterator<TileTree, any, undefined> | Iterates all trees in the set. | |
add(tree: TileTree): void | Adds the specified tree to the set. | |
clear(): void | Clear the contents of this set. | |
disclose(discloser: TileTreeDiscloser): void | Add all tile trees referenced by discloser to the set. |
|
has(tree: TileTree): boolean | Returns true if the specified tree has been DisclosedTileTreeSet.added to the set. |
Properties
Name | Type | Description | |
---|---|---|---|
size Accessor ReadOnly | number | The number of trees in the set. |
Defined in
Last Updated: 20 June, 2023