RenderClipVolume Class
An opaque representation of a clip volume applied to geometry within a Viewport. A RenderClipVolume is created from a ClipVector and takes ownership of that ClipVector, expecting that it will not be modified while the RenderClipVolume still references it.
see RenderSystem.createClipVolume to create a clip volume.
extensions
Methods
Name | Description | |
---|---|---|
constructor(clipVector: ClipVector): RenderClipVolume Protected |
Properties
Name | Type | Description | |
---|---|---|---|
clipVector Readonly | ClipVector | The ClipVector from which this volume was created. |
Defined in
Last Updated: 20 June, 2023