TileDrawArgs Class
Provides context used when selecting and drawing Tiles.
see TileTree.draw
extensions
Methods
Name | Description | |
---|---|---|
constructor(params: TileDrawArgParams): TileDrawArgs | Constructor | |
addAppearanceProvider(provider: FeatureAppearanceProvider): void | Add a provider to supplement or override the symbology overrides for the view. | |
computePixelSizeInMetersAtClosestPoint(center: Point3d, radius: number): number | Compute the size in meters of one pixel at the point on a sphere closest to the camera. | |
drawGraphics(): void | Output graphics for all accumulated tiles. | |
drawGraphicsWithType(graphicType: TileGraphicType, graphics: GraphicBranch): void | Output graphics of the specified type for all accumulated tiles. | |
getPixelSize(tile: Tile): number | Compute the size in pixels of the specified tile at the point on its bounding sphere closest to the camera. | |
getPixelSizeInMetersAtClosestPoint(tile: Tile): number | Compute the size in meters of one pixel at the point on the tile's bounding sphere closest to the camera. | |
getRangePixelSize(range: Range3d): number | Compute this size of a sphere on screen in pixels | |
insertMissing(tile: Tile): void | Indicate that graphics for the specified tile are desired but not yet available. | |
markChildrenLoading(): void | Indicate that some requested child tiles are not yet loaded. | |
markReady(tile: Tile): void | Indicate that the specified tile should be displayed and that its graphics are ready to be displayed. | |
markUsed(tile: Tile): void | Indicate that the specified tile is being used for some purpose by the SceneContext's Viewport. |
Properties
Name | Type | Description | |
---|---|---|---|
_frustumPlanes Protected | undefined | FrustumPlanes | The planes of the viewing frustum, used for frustum culling. | |
appearanceProvider Accessor ReadOnly | undefined | FeatureAppearanceProvider | Optionally customizes aspects of the view's FeatureSymbology.Overrides. | |
boundingRange | undefined | Range3d | If defined, a bounding range in tile tree coordinates outside of which tiles should not be selected. | |
clipVolume | undefined | RenderClipVolume | Optional clip volume applied to the tiles. | |
context Readonly | SceneContext | The context in which the tiles will be drawn, exposing, e.g., the Viewport and accepting RenderGraphics to be drawn. | |
frustumPlanes Accessor ReadOnly | FrustumPlanes | The planes of the viewing frustum, used for frustum culling. | |
graphics Readonly | GraphicBranch | Holds the tile graphics to be drawn. | |
hiddenLineSettings | undefined | Settings | Optional overrides for the view's hidden line settings. | |
intersectionClip | undefined | ClipVector | If defined, tiles will be culled if they do not intersect this clip. | |
location Readonly | Transform | Transform to the location in iModel coordinates at which the tiles are to be drawn. | |
maxRealityTreeSelectionCount Accessor ReadOnly | undefined | number | ||
parentsAndChildrenExclusive | boolean | True if a tile and its child tiles should not be drawn simultaneously. | |
readyTiles Readonly | Set<Tile> | Tiles that we want to draw and that are ready to draw. | |
symbologyOverrides Accessor ReadOnly | undefined | FeatureSymbology.Overrides | If defined, replaces the view's own symbology overrides when drawing the tiles. | |
tileSizeModifier Accessor ReadOnly | number | A multiplier applied to a Tile's maximumSize property to adjust level of detail. |
|
tree Readonly | TileTree | The tile tree being drawn. | |
viewClip Readonly | undefined | ClipVector | Optional clip volume applied to all tiles in the view. | |
viewFlagOverrides Accessor ReadOnly | Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> | Overrides applied to the view's ViewFlags when drawing the tiles. | |
viewingSpace | ViewingSpace | Describes the viewed volume. | |
worldToViewMap Accessor ReadOnly | Map4d | Provides conversions between CoordSystem.World and CoordSystem.View. |
Defined in
Last Updated: 20 June, 2023