Map4d Class
Map4 carries two Matrix4d which are inverses of each other.
Implements
Methods
Name | Description | |
---|---|---|
clone(): Map4d | Return a clone of this Map4d | |
isAlmostEqual(other: Map4d): boolean | Test if both matrices are almost equal to those | |
multiplyMapMap(other: Map4d): Map4d | multiply this*other. | |
reverseInPlace(): void | Exchange the two matrices of the map. | |
sandwich0This1(other: Map4d): Map4d | return a Map4d whose transform0 is | |
sandwich1This0(other: Map4d): Map4d | return a Map4d whose transform0 is | |
setFrom(other: Map4d): void | Copy contents from another Map4d | |
setFromJSON(json: any): void | Set this map4d from a json object that the two Matrix4d values as properties named matrix0 and matrix1 | |
setIdentity(): void | Reinitialize this Map4d as an identity. | |
toJSON(): any | Return a json object {matrix0: value0, matrix1: value1} |
|
createBoxMap(lowA: Point3d, highA: Point3d, lowB: Point3d, highB: Point3d, result?: Map4d): undefined | Map4d Static | Create a mapping the scales and translates (no rotation) between boxes. | |
createIdentity(): Map4d Static | Create an identity map. | |
createRefs(matrix0: Matrix4d, matrix1: Matrix4d): Map4d Static | Create a Map4d, capturing the references to the two matrices. | |
createTransform(transform0: Transform, transform1?: Transform): undefined | Map4d Static | Create a Map4d with given transform pair. | |
createVectorFrustum(origin: Point3d, uVector: Vector3d, vVector: Vector3d, wVector: Vector3d, fraction: number): undefined | Map4d Static | Create a map between a frustum and world coordinates. | |
fromJSON(json?: any): Map4d Static | Create a map4d from a json object that the two Matrix4d values as properties named matrix0 and matrix1 |
Properties
Name | Type | Description | |
---|---|---|---|
transform0 Accessor ReadOnly | Matrix4d | Return a reference to (not copy of) the "forward" Matrix4d | |
transform1 Accessor ReadOnly | Matrix4d | Return a reference to (not copy of) the "reverse" Matrix4d |
Defined in
- geometry4d/Map4d.ts Line 18
Last Updated: 20 June, 2023