GraphicBranch Class
A node in a scene graph. The branch itself is not renderable. Instead it contains a list of RenderGraphics, and a transform, symbology overrides, and clip volume which are to be applied when rendering them. Branches can be nested to build an arbitrarily-complex scene graph.
extensions
Implements
Methods
Name | Description | |
---|---|---|
constructor(ownsEntries: boolean = false): GraphicBranch | Constructor | |
add(graphic: RenderGraphic): void | Add a graphic to this branch. | |
clear(): void | Empties the list of RenderGraphics contained in this branch, and if the GraphicBranch.ownsEntries flag is set, also disposes of them. | |
dispose(): void | Disposes of all graphics in this branch, if and only if GraphicBranch.ownsEntries is true. | |
getViewFlags(flags: ViewFlags): ViewFlags | Compute the view flags that result from applying this branch's GraphicBranch.viewFlagOverrides to the input flags. | |
setViewFlagOverrides(ovr: Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>>): void | Change GraphicBranch.viewFlagOverrides. | |
setViewFlags(flags: ViewFlags): void | Set GraphicBranch.viewFlagOverrides to override all ViewFlags as specified by flags . |
Properties
Name | Type | Description | |
---|---|---|---|
entries Readonly | RenderGraphic[] | The child nodes of this branch | |
isEmpty Accessor ReadOnly | boolean | Returns true if this branch contains no graphics. | |
ownsEntries Readonly | boolean | If true, when the branch is disposed of, the RenderGraphics in its entries array will also be disposed | |
realityModelDisplaySettings | undefined | RealityModelDisplaySettings | Controls how reality models are displayed within this branch. | Beta |
symbologyOverrides | undefined | FeatureSymbology.Overrides | Optional symbology overrides to be applied to all graphics in this branch | |
viewFlagOverrides | Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> | Selectively overrides the view's ViewFlags while drawing graphics within this branch. |
Defined in
Last Updated: 20 June, 2023