PresentationManager Class
Frontend Presentation manager which basically just forwards all calls to the backend implementation.
Implements
Methods
Name | Description | |
---|---|---|
dispose(): void | ||
getContent(requestOptions: ContentRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & { paging?: PageOptions } & ClientDiagnosticsAttribute): Promise<undefined | Content> | Retrieves content which consists of a content descriptor and a page of records. | |
getContentAndSize(requestOptions: ContentRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & { paging?: PageOptions } & ClientDiagnosticsAttribute): Promise<undefined | { content: Content, size: number }> | Retrieves content set size and content which consists of a content descriptor and a page of records. | |
getContentDescriptor(requestOptions: ContentDescriptorRequestOptions<IModelConnection, KeySet, RulesetVariable> & ClientDiagnosticsAttribute): Promise<undefined | Descriptor> | Retrieves the content descriptor which describes the content and can be used to customize it. | |
getContentInstanceKeys(requestOptions: ContentInstanceKeysRequestOptions<IModelConnection, KeySet, RulesetVariable> & ClientDiagnosticsAttribute): Promise<{ total: number, items: undefined }> | Retrieves content item instance keys. | |
getContentSetSize(requestOptions: ContentRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & ClientDiagnosticsAttribute): Promise<number> | Retrieves overall content set size. | |
getContentSources(requestOptions: ContentSourcesRequestOptions<IModelConnection> & ClientDiagnosticsAttribute): Promise<SelectClassInfo[]> | Get information about the sources of content when building it for specific ECClasses. | |
getDisplayLabelDefinition(requestOptions: DisplayLabelRequestOptions<IModelConnection, InstanceKey> & ClientDiagnosticsAttribute): Promise<LabelDefinition> | Retrieves display label definition of specific item. | |
getDisplayLabelDefinitions(requestOptions: DisplayLabelsRequestOptions<IModelConnection, InstanceKey> & ClientDiagnosticsAttribute): Promise<LabelDefinition[]> | Retrieves display label definition of specific items. | |
getElementProperties(requestOptions: SingleElementPropertiesRequestOptions<IModelConnection> & ClientDiagnosticsAttribute): Promise<undefined | ElementProperties> | Retrieves property data in a simplified format for a single element specified by ID. | |
getFilteredNodePaths(requestOptions: FilterByTextHierarchyRequestOptions<IModelConnection, RulesetVariable> & ClientDiagnosticsAttribute): Promise<NodePathElement[]> | Retrieves paths from root nodes to nodes containing filter text in their label. | |
getNodePaths(requestOptions: FilterByInstancePathsHierarchyRequestOptions<IModelConnection, RulesetVariable> & ClientDiagnosticsAttribute): Promise<NodePathElement[]> | Retrieves paths from root nodes to children nodes according to specified keys. | |
getNodes(requestOptions: HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> & { paging?: PageOptions } & ClientDiagnosticsAttribute): Promise<Node[]> | Retrieves nodes | |
getNodesAndCount(requestOptions: HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> & { paging?: PageOptions } & ClientDiagnosticsAttribute): Promise<{ count: number, nodes: Node[] }> | Retrieves total nodes count and a single page of nodes. | |
getNodesCount(requestOptions: HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> & ClientDiagnosticsAttribute): Promise<number> | Retrieves nodes count. | |
getNodesDescriptor(requestOptions: HierarchyLevelDescriptorRequestOptions<IModelConnection, NodeKey, RulesetVariable> & ClientDiagnosticsAttribute): Promise<undefined | Descriptor> | Retrieves hierarchy level descriptor. | Beta |
getPagedDistinctValues(requestOptions: DistinctValuesRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & ClientDiagnosticsAttribute): Promise<PagedResponse<DisplayValueGroup>> | Retrieves distinct values of specific field from the content. | |
rulesets(): RulesetManager | Get rulesets manager | |
vars(rulesetId: string): RulesetVariablesManager | Get ruleset variables manager for specific ruleset | |
create(props?: PresentationManagerProps): PresentationManager Static | Create a new PresentationManager instance |
Properties
Name | Type | Description | |
---|---|---|---|
activeLocale Accessor | undefined | string | Get / set active locale used for localizing presentation data | |
activeUnitSystem | undefined | UnitSystemKey | Get / set active unit system used to format property values with units |
Defined in
Last Updated: 20 June, 2023