Node Namespace
Function
Name | Description |
---|---|
Node.fromJSON | Deserialize Node from JSON |
Node.toJSON | Serialize given Node to JSON |
Defined in
Node Interface
Data structure that describes a tree node.
Properties
Name | Type | Description | |
---|---|---|---|
backColor | undefined | string | Background color | Deprecated |
description | undefined | string | Extensive description | |
extendedData | undefined | { T } | Extended data injected into this node | |
fontStyle | undefined | string | Font style | Deprecated |
foreColor | undefined | string | Foreground color | Deprecated |
hasChildren | undefined | boolean | Does this node have child nodes | |
imageId | undefined | string | Image ID | Deprecated |
isCheckboxEnabled | undefined | boolean | Is this node's checkbox enabled | Deprecated |
isCheckboxVisible | undefined | boolean | Is checkbox visible for this node | Deprecated |
isChecked | undefined | boolean | Is this node's checkbox checked | Deprecated |
isEditable | undefined | boolean | Is this node editable | |
isExpanded | undefined | boolean | Is this node expanded | |
isSelectionDisabled | undefined | boolean | Is this node selectable | |
key | NodeKey | A key that uniquely identifies a node. | |
label | LabelDefinition | Definition of node display label | |
supportsFiltering | undefined | boolean | Identifies whether the hierarchy level below this node supports filtering. | Beta |
Defined in
Last Updated: 20 June, 2023