Descriptor Class
Data structure that describes content: fields, sorting, filtering, format, etc. Descriptor may be changed to control how content is created.
Implements
Methods
Name | Description | |
---|---|---|
constructor(source: DescriptorSource): Descriptor | Construct a new Descriptor using a DescriptorSource | |
createDescriptorOverrides(): DescriptorOverrides | Create descriptor overrides object from this descriptor. | |
getFieldByName(name: string, recurse?: boolean): undefined | Field | Get field by its name | |
toJSON(): DescriptorJSON | Serialize Descriptor to JSON | |
fromJSON(json: undefined | DescriptorJSON): undefined | Descriptor Static | Deserialize Descriptor from JSON |
Properties
Name | Type | Description | |
---|---|---|---|
categories Readonly | CategoryDescription[] | A list of content field categories used in this descriptor | |
connectionId Readonly | undefined | string | Id of the connection used to create the descriptor | |
contentFlags Readonly | number | ContentFlags used to create the descriptor | |
contentOptions Readonly | any | Extended options used to create the descriptor. | Deprecated |
displayType Readonly | string | Display type used to create the descriptor | |
fields Readonly | Field[] | A list of fields contained in the descriptor | |
fieldsFilterExpression | undefined | string | ECExpression for filtering content by | |
filterExpression | undefined | string | ECExpression for filtering content | Deprecated |
inputKeysHash Readonly | undefined | string | Hash of the input keys used to create the descriptor | |
instanceFilter | undefined | InstanceFilterDefinition | Instances filter that allows filtering content by class, properties of specific class | Beta |
selectClasses Readonly | SelectClassInfo[] | A list of classes that will be selected when creating content with this descriptor | |
selectionInfo Readonly | undefined | SelectionInfo | Selection info used to create the descriptor | |
sortDirection | undefined | SortDirection | Sorting direction | |
sortingField | undefined | Field | Field used to sort the content |
Defined in
Last Updated: 20 June, 2023