SelectClassInfo Namespace
Function
Name | Description |
---|---|
SelectClassInfo.fromCompressedJSON | Deserialize SelectClassInfo from compressed JSON |
SelectClassInfo.toCompressedJSON | Serialize SelectClassInfo to compressed JSON |
Defined in
SelectClassInfo Interface
Data structure that describes an ECClass in content Descriptor.
Properties
Name | Type | Description | |
---|---|---|---|
isSelectPolymorphic | boolean | Is the class handled polymorphically | |
navigationPropertyClasses | undefined | RelatedClassInfo[] | Relationship paths to navigation property classes | |
pathFromInputToSelectClass | undefined | RelatedClassInfoWithOptionalRelationship[] | Relationship path from input class to the select class. | |
relatedInstancePaths | undefined | RelationshipPath[] | Relationship paths to related instance classes. | |
relatedPropertyPaths | undefined | RelationshipPath[] | Relationship paths to related property classes | |
selectClassInfo | ClassInfo | Information about the ECClass |
Defined in
Last Updated: 20 June, 2023