RelatedClassInfo Namespace
Function
Name | Description |
---|---|
RelatedClassInfo.equals | Check two RelatedClassInfo or StrippedRelatedClassInfo for equality |
RelatedClassInfo.fromCompressedJSON | Deserialize RelatedClassInfo from compressed JSON |
RelatedClassInfo.fromJSON | Deserialize RelatedClassInfo from JSON |
RelatedClassInfo.strip | Strip given RelatedClassInfo to StrippedRelatedClassInfo |
RelatedClassInfo.toCompressedJSON | Serialize RelatedClassInfo to compressed JSON |
RelatedClassInfo.toJSON | Serialize RelatedClassInfo to JSON |
Defined in
RelatedClassInfo Interface
A structure that describes a related class and the properties of that relationship.
Properties
Name | Type | Description | |
---|---|---|---|
isForwardRelationship | boolean | Should relationship be followed in a forward direction to access the related class. | |
isPolymorphicRelationship | undefined | boolean | Is relationship handled polymorphically | |
isPolymorphicTargetClass | undefined | boolean | Is target class handled polymorphically | |
relationshipInfo | ClassInfo | Information about the ECRelationship | |
sourceClassInfo | ClassInfo | Information about the source ECClass | |
targetClassInfo | ClassInfo | Information about the target ECClass |
Defined in
Last Updated: 20 June, 2023