ContentFlags Enumeration
Flags that control content format.
Members
Name | Value | Description |
---|---|---|
KeysOnly | 1 | Each content record only has InstanceKey and no data |
ShowImages | 2 | Each content record additionally has an image id |
ShowLabels | 4 | Each content record additionally has a display label |
MergeResults | 8 | All content records are merged into a single record (see Merging values) |
DistinctValues | 16 | Content has only distinct values |
NoFields | 32 | Doesn't create property or calculated fields. Can be used in conjunction with ContentFlags.ShowLabels. |
IncludeInputKeys | 256 | Set related input keys on Item objects when creating content. This helps identify which Item is associated to which given input key at the cost of performance creating those items. |
DescriptorOnly | 512 | Produce content descriptor that is not intended for querying content. Allows the implementation to omit certain operations to make obtaining content descriptor faster. internal |
Defined in
Last Updated: 20 June, 2023