DescriptorOverrides Interface
Descriptor overrides that can be used to customize content
Properties
Name | Type | Description | |
---|---|---|---|
contentFlags | undefined | number | Content flags used for content customization. | |
displayType | undefined | string | Content display type. | |
fieldsFilterExpression | undefined | string | ECExpression for filtering content by | |
fieldsSelector | undefined | { fields: FieldDescriptor[], type: "include" | "exclude" } | Fields selector that allows excluding or including only specified fields. | |
filterExpression | undefined | string | ECExpression for filtering content | Deprecated |
instanceFilter | undefined | InstanceFilterDefinition | Instances filter that allows filtering content by class, properties of specific class | Beta |
sorting | undefined | { direction: SortDirection, field: FieldDescriptor } | Specification for sorting data. |
Defined in
Last Updated: 20 June, 2023