DescriptorSource Interface
Descriptor properties
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
categories Readonly | CategoryDescription[] | A list of content field categories used in this descriptor | |
connectionId Readonly | undefined | string | Id of the connection used to create the descriptor | |
contentFlags Readonly | number | ContentFlags used to create the descriptor | |
displayType Readonly | string | Display type used to create the descriptor | |
fields Readonly | Field[] | A list of fields contained in the descriptor | |
fieldsFilterExpression | undefined | string | ECExpression for filtering content by | |
filterExpression | undefined | string | ECExpression for filtering content | Deprecated |
inputKeysHash Readonly | undefined | string | Hash of the input keys used to create the descriptor | |
instanceFilter | undefined | InstanceFilterDefinition | Instances filter that allows filtering content by class, properties of specific class | Beta |
selectClasses Readonly | SelectClassInfo[] | A list of classes that will be selected from when creating content with this descriptor | |
selectionInfo Readonly | undefined | SelectionInfo | Selection info used to create the descriptor | |
sortDirection Readonly | undefined | SortDirection | Sorting direction | |
sortingField Readonly | undefined | Field | Field used to sort the content |
Defined in
Last Updated: 20 June, 2023