Field Class
Describes a single content field. A field is usually represented as a grid column or a property pane row.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(category: CategoryDescription, name: string, label: string, type: TypeDescription, isReadonly: boolean, priority: number, editor?: EditorDescription, renderer?: RendererDescription): Field | Creates an instance of Field. | |
clone(): Field | ||
getFieldDescriptor(): FieldDescriptor | Get descriptor for this field. | |
isNestedContentField(): this is NestedContentField | Is this a NestedContentField | |
isPropertiesField(): this is PropertiesField | Is this a PropertiesField | |
toCompressedJSON(classesMap: { T }): FieldJSON<string> | Serialize this object to compressed JSON | |
toJSON(): FieldJSON<ClassInfoJSON> | Serialize this object to JSON | |
fromCompressedJSON(json: undefined | FieldJSON<string>, classesMap: { T }, categories: CategoryDescription[]): undefined | Field Static | Deserialize a Field from compressed JSON. | |
fromJSON(json: undefined | FieldJSON<ClassInfoJSON>, categories: CategoryDescription[]): undefined | Field Static | Deserialize Field from JSON | |
getCategoryFromFieldJson(fieldJson: FieldJSON<ClassInfoJSON>, categories: CategoryDescription[]): CategoryDescription ProtectedStatic |
Properties
Name | Type | Description | |
---|---|---|---|
category | CategoryDescription | Category information | |
editor | undefined | EditorDescription | Property editor used to edit values of this field | |
isReadonly | boolean | Are values in this field read-only | |
label | string | Display label | |
name | string | Unique name | |
parent Accessor ReadOnly | undefined | NestedContentField | Get parent | |
priority | number | Priority of the field. | |
renderer | undefined | RendererDescription | Property renderer used to render values of this field | |
type | TypeDescription | Description of this field's values data type |
Defined in
Last Updated: 20 June, 2023