NestedContentField Class
Describes a content field that contains Nested content.
Extends
Methods
Name | Description | |
---|---|---|
constructor(category: CategoryDescription, name: string, label: string, description: TypeDescription, isReadonly: boolean, priority: number, contentClassInfo: ClassInfo, pathToPrimaryClass: RelationshipPath, nestedFields: Field[], editor?: EditorDescription, autoExpand?: boolean, renderer?: RendererDescription): NestedContentField | Creates an instance of NestedContentField. | |
clone(): NestedContentField | ||
getFieldByName(name: string, recurse?: boolean): undefined | Field | Get field by its name | |
toJSON(): NestedContentFieldJSON<ClassInfoJSON> | Serialize this object to JSON | |
fromCompressedJSON(json: NestedContentFieldJSON<string>, classesMap: { T }, categories: CategoryDescription[]): any Static | Deserialize a NestedContentField from compressed JSON. | |
fromJSON(json: undefined | NestedContentFieldJSON<ClassInfoJSON>, categories: CategoryDescription[]): undefined | NestedContentField Static | Deserialize NestedContentField from JSON | Deprecated |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getFieldDescriptor(): FieldDescriptor | Field | Get descriptor for this field. |
isNestedContentField(): this is NestedContentField | Field | Is this a NestedContentField |
isPropertiesField(): this is PropertiesField | Field | Is this a PropertiesField |
toCompressedJSON(classesMap: { T }): FieldJSON<string> | Field | Serialize this object to compressed JSON |
getCategoryFromFieldJson(fieldJson: FieldJSON<ClassInfoJSON>, categories: CategoryDescription[]): CategoryDescription ProtectedStatic | Field |
Properties
Name | Type | Description | |
---|---|---|---|
actualPrimaryClassIds | string[] | When content descriptor is requested in a polymorphic fashion, fields get created if at least one of the concrete classes | Beta |
autoExpand | undefined | boolean | Flag specifying whether field should be expanded | |
contentClassInfo | ClassInfo | Information about an ECClass whose properties are nested inside this field | |
nestedFields | Field[] | Contained nested fields | |
pathToPrimaryClass | RelationshipPath | Relationship path to Primary class | |
relationshipMeaning | RelationshipMeaning | Meaning of the relationship between the primary class |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category | CategoryDescription | Field | Category information |
editor | undefined | EditorDescription | Field | Property editor used to edit values of this field |
isReadonly | boolean | Field | Are values in this field read-only |
label | string | Field | Display label |
name | string | Field | Unique name |
parent Accessor ReadOnly | undefined | NestedContentField | Field | Get parent |
priority | number | Field | Priority of the field. |
renderer | undefined | RendererDescription | Field | Property renderer used to render values of this field |
type | TypeDescription | Field | Description of this field's values data type |
Defined in
Last Updated: 20 June, 2023