PropertiesField Class
Describes a content field that's based on one or more similar
EC properties.
Extends
Methods
Name |
Description |
|
constructor(category: CategoryDescription, name: string, label: string, description: TypeDescription, isReadonly: boolean, priority: number, properties: Property[], editor?: EditorDescription, renderer?: RendererDescription): PropertiesField |
Creates an instance of PropertiesField. |
|
clone(): PropertiesField |
|
|
getFieldDescriptor(): FieldDescriptor |
Get descriptor for this field. |
|
toJSON(): PropertiesFieldJSON<ClassInfoJSON> |
Serialize this object to JSON |
|
fromCompressedJSON(json: PropertiesFieldJSON<string>, classesMap: { T }, categories: CategoryDescription[]): undefined | PropertiesField Static |
Deserialize a PropertiesField from compressed JSON. |
|
fromJSON(json: undefined | PropertiesFieldJSON<ClassInfoJSON>, categories: CategoryDescription[]): undefined | PropertiesField Static |
Deserialize PropertiesField from JSON |
|
Inherited methods
Properties
Name |
Type |
Description |
|
properties |
Property[] |
A list of properties this field is created from |
|
Inherited properties
Defined in
Last Updated:
20 June, 2023