PropertiesFieldJSON<TClassInfoJSON> Interface
Data structure for a PropertiesField serialized to JSON.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
properties | PropertyJSON<TClassInfoJSON>[] |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category | string | BaseFieldJSON | |
editor | undefined | EditorDescription | BaseFieldJSON | |
isReadonly | boolean | BaseFieldJSON | |
label | string | BaseFieldJSON | |
name | string | BaseFieldJSON | |
priority | number | BaseFieldJSON | |
renderer | undefined | RendererDescription | BaseFieldJSON | |
type | TypeDescription | BaseFieldJSON |
Defined in
Last Updated: 20 June, 2023