HierarchyRequestOptions<TIModel, TNodeKey, TRulesetVariable> Interface
Request type for hierarchy requests.
Extends
- RequestOptionsWithRuleset<TIModel, TRulesetVariable>
Properties
Name | Type | Description | |
---|---|---|---|
instanceFilter | undefined | InstanceFilterDefinition | An instance filter that should be applied for this hierarchy level. | Beta |
parentKey | undefined | TNodeKey | Key of the parent node to get children for |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
imodel | TIModel | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | iModel to request data from |
locale | undefined | string | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Optional locale to use when formatting / localizing data |
rulesetOrId | string | Ruleset | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Ruleset or id of the ruleset to use when requesting data |
rulesetVariables | undefined | TRulesetVariable[] | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Ruleset variables to use when requesting data |
unitSystem | undefined | UnitSystemKey | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Unit system to use when formatting property values with units. |
Defined in
Last Updated: 20 June, 2023