RequestOptionsWithRuleset<TIModel, TRulesetVariable> Interface
Options for requests that require presentation ruleset. Not meant to be used directly, see one of the subclasses.
Extends
- RequestOptions<TIModel>
Properties
Name | Type | Description | |
---|---|---|---|
rulesetOrId | string | Ruleset | Ruleset or id of the ruleset to use when requesting data | |
rulesetVariables | undefined | TRulesetVariable[] | Ruleset variables to use when requesting data |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
imodel | TIModel | RequestOptions<TIModel> | iModel to request data from |
locale | undefined | string | RequestOptions<TIModel> | Optional locale to use when formatting / localizing data |
unitSystem | undefined | UnitSystemKey | RequestOptions<TIModel> | Unit system to use when formatting property values with units. |
Defined in
Last Updated: 20 June, 2023