Ruleset Interface
Presentation ruleset is a list of rules that define tree hierarchy and content provided by the presentation library. The ruleset consists of:
- Ruleset options
- Hierarchy rules:
- Root node rules
- Child node rules
- Content rules for content you see in content controls like property grid and table.
- Customization rules used for additional customizations such as styling, labeling, checkboxes, etc.
- User-controllable variables.
see Presentation library documentation page
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
id | string | Ruleset identifier. | |
requiredSchemas | undefined | RequiredSchemaSpecification[] | Schema requirements for this ruleset. | |
rules | Rule[] | Presentation rules used to create hierarchies and content | |
supplementationInfo | undefined | SupplementationInfo | Supplementation-related information for this ruleset | |
vars | undefined | VariablesGroup[] | User-controllable variable definitions | |
version | undefined | string | Version of the presentation ruleset in SemVer format: {major}.{minor}.{patch} . |
Beta |
Defined in
Last Updated: 20 June, 2023