DistinctValuesRequestOptions<TIModel, TDescriptor, TKeySet, TRulesetVariable> Interface
Request type for distinct values' requests.
Extends
- Paged<RequestOptionsWithRuleset<TIModel, TRulesetVariable>>
Properties
Name | Type | Description | |
---|---|---|---|
descriptor | TDescriptor | Content descriptor for customizing the returned content | |
fieldDescriptor | FieldDescriptor | Descriptor for a field distinct values are requested for | |
keys | TKeySet | Input keys for getting the content |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
imodel | TIModel | Paged | iModel to request data from |
locale | undefined | string | Paged | Optional locale to use when formatting / localizing data |
paging | undefined | PageOptions | Paged | Optional paging parameters |
rulesetOrId | string | Ruleset | Paged | Ruleset or id of the ruleset to use when requesting data |
rulesetVariables | undefined | TRulesetVariable[] | Paged | Ruleset variables to use when requesting data |
unitSystem | undefined | UnitSystemKey | Paged | Unit system to use when formatting property values with units. |
Defined in
Last Updated: 20 June, 2023