Rendering
Types describing geometry, views, and symbology for consumption by a display system.
Classes
Name | Description | |
---|---|---|
Feature | Describes a discrete entity within a batched RenderGraphic that can be | |
FeatureAppearance | Defines overrides for selected aspects of a Feature's symbology. | |
FeatureOverrides | Specifies how to customize the appearance of individual Features, typically within the context of a Viewport. | |
FeatureTable | Defines a look-up table for Features within a batched RenderGraphic. | |
ImageBuffer | Uncompressed rectangular bitmap image data. | |
ImageSource | Image data encoded and compressed in either Jpeg or Png format. | |
OctEncodedNormal | Represents a 3d normal vector compressed into a single 16-bit integer using oct-encoding. | |
RenderMaterial | Represents a material which can be applied to a surface to control aspects of its appearance such as color, reflectivity, texture, and so on. | |
RenderTexture | Represents a texture image applied to a surface during rendering. | |
TextureMapping | Describes how to map a RenderTexture's image onto a surface as part of a RenderMaterial. |
Enumerations
Name | Description | |
---|---|---|
BatchType | Describes the type of a 'batch' of graphics representing multiple Features. | |
FeatureOverrideType | Options for overriding element appearance. | |
ImageBufferFormat | Format of an ImageBuffer. | |
ImageSourceFormat | The format of an ImageSource. | |
NormalMapFlags | Flags applied to a NormalMapProps. | |
TextureMapUnits | Describes the units in which a TextureMapProps' scale is expressed. |
Global Functions
Name | Description | |
---|---|---|
isPowerOfTwo | Returns whether the input is a power of two. | |
nextHighestPowerOfTwo | Returns the first power-of-two value greater than or equal to the input. |
Interfaces
Name | Description | |
---|---|---|
AppearanceOverrideProps | JSON representation of an appearance override in an EmphasizeElementsProps. | |
EmphasizeElementsProps | JSON representation of an EmphasizeElements. | |
FeatureAppearanceProps | JSON representation of a FeatureAppearance. | |
FeatureAppearanceProvider | Interface adopted by an object that can supply the FeatureAppearance supplied by a FeatureAppearanceSource. | |
FeatureAppearanceSource | Interface adopted by an object that can supply a FeatureAppearance given a low-level description of a Feature. | |
IgnoreAnimationOverridesArgs | Arguments provided to a function of type IgnoreAnimationOverrides. | |
NormalMapParams | Defines normal map parameters. | Beta |
NormalMapProps | Describes how to apply normal mapping to a surface material. | |
OverrideElementAppearanceOptions | Options for using FeatureOverrides.override to override the appearance of a GeometricElement. | |
OverrideFeatureAppearanceOptions | Common options for FeatureOverrides.override. | |
OverrideModelAppearanceOptions | Options for using FeatureOverrides.override to override the appearance of a GeometricModel. | |
OverrideSubCategoryAppearanceOptions | Options for using FeatureOverrides.override to override the appearance of a SubCategory. | |
RenderMaterialAssetMapsProps | Describes different types of textures to be applied to a surface material to alter its appearance. | |
RenderMaterialAssetProps | Describes the graphical properties of a RenderMaterialElement as part of a RenderMaterialProps. | |
RenderMaterialProps | Properties that define a RenderMaterialElement. | |
TextureMapProps | As part of a RenderMaterialAssetProps, describes how to map a RenderTexture's image to the triangles of a mesh to which the material is applied. | |
ThumbnailFormatProps | Metadata about a thumbnail image. | |
ThumbnailProps | Describes a thumbnail image for an IModel or ViewDefinition. |
Namespaces
Name | Description | |
---|---|---|
FeatureAppearanceProvider | ||
Hilite | Contains types related to display of hilited elements within a Viewport. | |
RenderMaterial | ||
RenderTexture | ||
TextureMapping |
Type Aliases
Name | Description | |
---|---|---|
IgnoreAnimationOverrides | ||
OverrideFeatureAppearanceArgs | Arguments supplied to FeatureOverrides.override. | |
Point2dProps | A 2d point specified as an array of 2 numbers [x, y]. | |
RgbFactorProps | Describes a color as an array of three numbers ranging from 0 to 1 where the first entry corresponds to the color's red component, | |
TextureImageSpec | Identifies an image to be used to produce a RenderTexture for a given purpose - for example, |
Last Updated: 20 June, 2023