PresentationTableDataProvider Class
Deprecated in 3.x. Based on Table component which is deprecated
Presentation Rules-driven table data provider.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: PresentationTableDataProviderProps): PresentationTableDataProvider | Constructor. | |
getDescriptorOverrides(): Promise<DescriptorOverrides> Protected | Provides content configuration for the property grid | |
getLoadedRow(rowIndex: number): undefined | Readonly<RowItem> | Try to get a loaded row. | |
getRow(rowIndex: number): Promise<RowItem> | Get a single row. | |
getRowKey(row: RowItem): InstanceKey | Get key of ECInstance that's represented by the supplied row | |
getRowsCount(): Promise<number> | Get the total number of rows. | |
invalidateCache(props: CacheInvalidationProps): void Protected | Invalidates cached content. | |
sort(columnIndex: number, sortDirection: SortDirection): Promise<void> | Sorts the data in this data provider. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
dispose(): void | ContentDataProvider | Destructor. |
getContent(pageOptions?: PageOptions): Promise<undefined | Content> | ContentDataProvider | Get the content. |
getContentSetSize(): Promise<number> | ContentDataProvider | Get the number of content records. |
getFieldByPropertyRecord(propertyRecord: PropertyRecord): Promise<undefined | Field> | ContentDataProvider | Get field using PropertyRecord. |
shouldRequestContentForEmptyKeyset(): boolean Protected | ContentDataProvider | Called to check if content should be requested even when keys is empty. |
Properties
Name | Type | Description | |
---|---|---|---|
filterExpression Accessor | undefined | string | ECExpression for filtering data in the table. |
|
getColumns | Memoized<() => Promise<ColumnDescription[]>> | Returns column definitions. | |
onColumnsChanged | TableDataChangeEvent | ||
onRowsChanged | TableDataChangeEvent | ||
sortColumn Accessor ReadOnly | Promise<undefined | ColumnDescription> | Get the column which is used for sorting data in the table. | |
sortColumnKey Accessor ReadOnly | undefined | string | Get key of the column which is used for sorting data in the table. | |
sortDirection Accessor ReadOnly | SortDirection | Get sort direction. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
displayType Accessor ReadOnly | string | ContentDataProvider | Display type used to format content |
getContentDescriptor | Memoized<() => Promise<undefined | Descriptor>> | ContentDataProvider | Get the content descriptor. |
imodel Accessor | IModelConnection | ContentDataProvider | IModel to pull data from |
keys Accessor | KeySet | ContentDataProvider | Keys defining what to request content for |
pagingSize Accessor | undefined | number | ContentDataProvider | Paging options for obtaining content. |
rulesetId Accessor | string | ContentDataProvider | Id of the ruleset to use when requesting content |
selectionInfo Accessor | undefined | SelectionInfo | ContentDataProvider | Information about selection event that results in content change |
Defined in
Last Updated: 20 June, 2023