PresentationTableDataProviderProps Interface
Deprecated in 3.x. Used by PresentationTableDataProvider which is deprecated
Initialization properties for PresentationTableDataProvider
Extends
Properties
Name | Type | Description | |
---|---|---|---|
cachedPagesCount | undefined | number | Number of pages cached in the data provider. | |
displayType | undefined | string | Display type to use when requesting data from the backend. | |
enableContentAutoUpdate | undefined | boolean | Auto-update table content when ruleset, ruleset variables or data in the iModel changes. | |
imodel | IModelConnection | IModel to pull data from | |
pageSize | undefined | number | Number of rows in a single page requested from the backend. | |
ruleset | string | Ruleset | Ruleset or it's ID to be used for creating the content |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
ruleDiagnostics | undefined | { handler: ClientDiagnosticsHandler, severity?: DiagnosticsLoggerSeverity } | DiagnosticsProps | Settings for capturing rule diagnostics. |
Defined in
Last Updated: 20 June, 2023