ColumnDescription Interface
Deprecated in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
Column definition provided to Table.
Properties
Name | Type | Description | |
---|---|---|---|
editable | undefined | boolean | Indicates whether the cells in the column are editable. | |
filterCaseSensitive | undefined | boolean | Filtering is case-sensitive in Multi-Value column filtering popup. | |
filterRenderer | undefined | FilterRenderer | Specifies the filter renderer for the column. | |
filterable | undefined | boolean | Indicates whether the column is filterable. | |
icon | undefined | boolean | Indicates whether the display value for the cell is treated as an icon spec. | |
key | string | A unique key for this column. | |
label | string | Column header label | |
propertyDescription | undefined | PropertyDescription | Property description for all cells in the column | |
resizable | undefined | boolean | Indicates whether the column is resizable. | |
secondarySortColumn | undefined | number | Specifies a secondary sort column to use when cell values are the same. | |
showDistinctValueFilters | undefined | boolean | Show distinct value checkboxes in Multi-Value column filtering popup. | |
showFieldFilters | undefined | boolean | Show field filters in Multi-Value column filtering popup. | |
sortIgnoreCase | undefined | boolean | Indicates whether the column sorting ignores case. | |
sortType | undefined | string | Sort type for react-table | |
sortable | undefined | boolean | Indicates whether the column is sortable. | |
width | undefined | number | Preferred initial width of the column |
Defined in
Last Updated: 20 June, 2023