RowItem Interface
Deprecated in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
Row definition provided to Table.
Methods
Name | Description | |
---|---|---|
getValueFromCell(columnKey: string): any Optional | Get the value from the cell for filtering purposes. |
Properties
Name | Type | Description | |
---|---|---|---|
cells | CellItem[] | Array of cells in the row | |
colorOverrides | undefined | ItemColorOverrides | Color overrides for all cells in the row | |
extendedData | undefined | { T } | A key-value pairs data structure that can be used by data provider | |
isDisabled | undefined | boolean | Indicates whether the row is disabled | |
key | string | A unique key for this row |
Defined in
Last Updated: 20 June, 2023