CellItem Interface
Deprecated in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
Cell definition provided to Table.
Properties
Name | Type | Description | |
---|---|---|---|
alignment | undefined | HorizontalAlignment | Specifies the horizontal alignment of the contents of the cell | |
isDisabled | undefined | boolean | Indicates whether the cell is disabled | |
key | string | Key for the column containing the cell | |
mergedCellsCount | undefined | number | Property to specify how many cells were merged to create this cell. | |
record | undefined | PropertyRecord | Property record for the cell | |
style | undefined | ItemStyle | Style properties for the contents of the cell |
Defined in
Last Updated: 20 June, 2023