AddEffectTool Class
Beta
Adds a screen-space effect to the selected viewport.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): AddEffectTool | ||
defineEffect(builder: ScreenSpaceEffectBuilder): void ProtectedAbstract | Add uniforms, varyings, etc. | |
run(): Promise<boolean> |
Inherited methods
Name | Inherited from | Description |
---|---|---|
parseAndRun(..._args: string[]): Promise<boolean> | Tool | Run this instance of a tool using a series of string arguments. |
register(namespace?: string): void Static | Tool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
effectName Accessor ProtectedAbstractReadOnly | string | Name of effect as used in keyins like fdt effect add . |
|
source Accessor ProtectedAbstractReadOnly | ScreenSpaceEffectSource | vertex, fragment, and optional sampleSourcePixel GLSL snippets. | |
textureCoordFromPosition Accessor ProtectedAbstractReadOnly | boolean | Whether the fragment shader should include built-in textureCoordFromPosition function. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description Accessor ReadOnly | string | Tool | Get the localized description string from this Tool's class |
description Accessor StaticReadOnly | string | Tool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, flyover is returned. |
englishKeyin Accessor StaticReadOnly | string | Tool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | Tool | Get the localized flyover string from this Tool's class |
flyover Accessor StaticReadOnly | string | Tool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, keyin is returned. |
hidden Static | boolean | Tool | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor ReadOnly | string | Tool | Get the iconSpec from this Tool's class. |
iconSpec Static | string | Tool | The icon for this Tool. |
keyin Accessor ReadOnly | string | Tool | Get the localized keyin string from this Tool's class |
keyin Accessor StaticReadOnly | string | Tool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
maxArgs Accessor StaticReadOnly | undefined | number | Tool | The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum. If subclasses override parseAndRun, they should also override this method to indicate the maximum number of arguments their implementation expects. |
minArgs Accessor StaticReadOnly | number | Tool | The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also override this method to indicate the minimum number of arguments their implementation expects. UI controls can use this information to ensure the tool has enough information to execute. |
namespace Static | string | Tool | The namespace that provides localized strings for this Tool. |
toolId Accessor ReadOnly | string | Tool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
toolId Static | string | Tool | The unique string that identifies this tool. |
Defined in
Last Updated: 20 June, 2023