parseAndRun Method
Run this instance of a tool using a series of string arguments. Override this method to parse the arguments, and if they're
acceptable, execute your Tool.run method. If the arguments aren't valid, return false
.
parseAndRun(..._args: string[]): Promise<boolean>
note if you override this method, you must also override the static Tool.minArgs and Tool.maxArgs getters.
note Generally, implementers of this method are not expected to call super.parseAndRun(...)
. Instead, call your
Tool.run method with the appropriate (parsed) arguments directly.
Parameter | Type | Description |
---|---|---|
..._args | string[] |
Returns - Promise<boolean>
Defined in
- core/frontend/src/tools/Tool.ts Line 478
Last Updated: 20 June, 2023