ConvolutionEffect Class
Beta
Adds one of a collection of "convolution kernels" that alter a Viewport's image by blending neighboring pixels. Based on https://webglfundamentals.org/webgl/lessons/webgl-image-processing-continued.html
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): ConvolutionEffect | ||
defineEffect(builder: ScreenSpaceEffectBuilder): void Protected | Add uniforms, varyings, etc. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
parseAndRun(..._args: string[]): Promise<boolean> | AddEffectTool | Run this instance of a tool using a series of string arguments. |
run(): Promise<boolean> | AddEffectTool | |
register(namespace?: string): void Static | AddEffectTool | Register this Tool class with the ToolRegistry. |
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description Accessor ReadOnly | string | AddEffectTool | Get the localized description string from this Tool's class |
description Accessor StaticReadOnly | string | AddEffectTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, AddEffectTool.flyover is returned. |
effectName Accessor ProtectedAbstractReadOnly | string | AddEffectTool | Name of effect as used in keyins like fdt effect add . Ideally one word. |
englishKeyin Accessor StaticReadOnly | string | AddEffectTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | AddEffectTool | Get the localized flyover string from this Tool's class |
flyover Accessor StaticReadOnly | string | AddEffectTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, AddEffectTool.keyin is returned. |
hidden Static | boolean | AddEffectTool | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor ReadOnly | string | AddEffectTool | Get the iconSpec from this Tool's class. |
iconSpec Static | string | AddEffectTool | The icon for this Tool. |
keyin Accessor ReadOnly | string | AddEffectTool | Get the localized keyin string from this Tool's class |
keyin Accessor StaticReadOnly | string | AddEffectTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
namespace Static | string | AddEffectTool | The namespace that provides localized strings for this Tool. |
toolId Accessor ReadOnly | string | AddEffectTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
toolId Static | string | AddEffectTool | The unique string that identifies this tool. |
Defined in
Last Updated: 20 June, 2023