EdgeDetectionEffect Class
Beta
Adds a screen-space edge-detection effect to the selected Viewport.
Extends
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): EdgeDetectionEffect |
Inherited methods
Name | Inherited from | Description |
---|---|---|
defineEffect(builder: ScreenSpaceEffectBuilder): void Protected | ConvolutionEffect | Add uniforms, varyings, etc. |
parseAndRun(..._args: string[]): Promise<boolean> | ConvolutionEffect | Run this instance of a tool using a series of string arguments. |
run(): Promise<boolean> | ConvolutionEffect | |
register(namespace?: string): void Static | ConvolutionEffect | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
effectName Accessor ProtectedReadOnly | string | ||
matrix Accessor ProtectedReadOnly | number[] | ||
toolId Static | string | The unique string that identifies this tool. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description Accessor ReadOnly | string | ConvolutionEffect | Get the localized description string from this Tool's class |
description Accessor StaticReadOnly | string | ConvolutionEffect | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, ConvolutionEffect.flyover is returned. |
englishKeyin Accessor StaticReadOnly | string | ConvolutionEffect | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | ConvolutionEffect | Get the localized flyover string from this Tool's class |
flyover Accessor StaticReadOnly | string | ConvolutionEffect | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, ConvolutionEffect.keyin is returned. |
hidden Static | boolean | ConvolutionEffect | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor ReadOnly | string | ConvolutionEffect | Get the iconSpec from this Tool's class. |
iconSpec Static | string | ConvolutionEffect | The icon for this Tool. |
keyin Accessor ReadOnly | string | ConvolutionEffect | Get the localized keyin string from this Tool's class |
keyin Accessor StaticReadOnly | string | ConvolutionEffect | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
maxArgs Accessor StaticReadOnly | number | ConvolutionEffect | |
minArgs Accessor StaticReadOnly | number | ConvolutionEffect | |
namespace Static | string | ConvolutionEffect | The namespace that provides localized strings for this Tool. |
source Accessor ProtectedReadOnly | { fragment: string, vertex: string } | ConvolutionEffect | |
textureCoordFromPosition Accessor ProtectedReadOnly | boolean | ConvolutionEffect | |
toolId Accessor ReadOnly | string | ConvolutionEffect | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
Defined in
Last Updated: 20 June, 2023