toolId Static
toolId: string = ""
The unique string that identifies this tool. This must be overridden in every subclass.
Defined in
- core/frontend/src/tools/Tool.ts Line 362
toolId
AccessorReadOnly
Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale.
toolId: string
Returns - string
Defined in
- core/frontend/src/tools/Tool.ts Line 444
Last Updated: 20 June, 2023