SchemaItem Class
Beta
An abstract class that supplies all of the common parts of a SchemaItem.
Extended by
- ECClass
- Constant
- Enumeration
- Format
- InvertedUnit
- KindOfQuantity
- Phenomenon
- PropertyCategory
- Unit
- UnitSystem
Methods
Name | Description | |
---|---|---|
constructor(schema: Schema, name: string): SchemaItem | ||
fromJSON(schemaItemProps: SchemaItemProps): Promise<void> | ||
fromJSONSync(schemaItemProps: SchemaItemProps): void | ||
toJSON(standalone: boolean = false, includeSchemaVersion: boolean = false): SchemaItemProps | Save this SchemaItem's properties to an object for serializing to JSON. | |
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItem | SchemaItemKey): boolean Static | Indicates if the two SchemaItem objects are equal by comparing their respective SchemaItem.key properties. | |
parseFullName(fullName: string): [string, string] Static | Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings. |
Properties
Name | Type | Description | |
---|---|---|---|
_description Protected | undefined | string | ||
_key Protected | SchemaItemKey | ||
_label Protected | undefined | string | ||
description Accessor ReadOnly | undefined | string | ||
fullName Accessor ReadOnly | string | ||
key Accessor ReadOnly | SchemaItemKey | ||
label Accessor ReadOnly | undefined | string | ||
name Accessor ReadOnly | string | ||
schema Readonly | Schema | ||
schemaItemType Readonly | SchemaItemType |
Defined in
Last Updated: 20 June, 2023