SchemaItemKey Class
Beta
The SchemaItemKey contains a SchemaItem's name and SchemaKey.
Methods
Name | Description | |
---|---|---|
constructor(name: string, schema: SchemaKey): SchemaItemKey | ||
matches(rhs: SchemaItemKey): boolean | Checks whether this SchemaItemKey matches the one provided. | |
matchesFullName(name: string): boolean |
Properties
Name | Type | Description | |
---|---|---|---|
_schemaKey Protected | SchemaKey | ||
fullName Accessor ReadOnly | string | Returns the name in the format, {schemaName}.{name}. | |
name Accessor ReadOnly | string | ||
schemaKey Accessor ReadOnly | SchemaKey | ||
schemaName Accessor ReadOnly | string |
Defined in
Last Updated: 20 June, 2023