Phenomenon Class
Beta
Extends
Methods
Name | Description | |
---|---|---|
constructor(schema: Schema, name: string): Phenomenon | ||
fromJSON(phenomenonProps: PhenomenonProps): Promise<void> | ||
fromJSONSync(phenomenonProps: PhenomenonProps): void | ||
setDefinition(definition: string): Promise<void> Protected | ||
toJSON(standalone: boolean = false, includeSchemaVersion: boolean = false): PhenomenonProps | Save this Phenomenon's properties to an object for serializing to JSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItem | SchemaItemKey): boolean Static | SchemaItem | Indicates if the two SchemaItem objects are equal by comparing their respective SchemaItem.key properties. |
parseFullName(fullName: string): [string, string] Static | SchemaItem | Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings. |
Properties
Name | Type | Description | |
---|---|---|---|
_definition Protected | string | ||
definition Accessor ReadOnly | string | ||
schemaItemType Readonly | Phenomenon |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_description Protected | undefined | string | SchemaItem | |
_key Protected | SchemaItemKey | SchemaItem | |
_label Protected | undefined | string | SchemaItem | |
description Accessor ReadOnly | undefined | string | SchemaItem | |
fullName Accessor ReadOnly | string | SchemaItem | |
key Accessor ReadOnly | SchemaItemKey | SchemaItem | |
label Accessor ReadOnly | undefined | string | SchemaItem | |
name Accessor ReadOnly | string | SchemaItem | |
schema Readonly | Schema | SchemaItem |
Defined in
Last Updated: 20 June, 2023