InvertedUnit Class
Beta
An InvertedUnit is a specific type of Unit that describes the inverse of a single Unit whose dimensional derivation is unit-less.
Extends
Methods
Name | Description | |
---|---|---|
constructor(schema: Schema, name: string): InvertedUnit | ||
fromJSON(invertedUnitProps: InvertedUnitProps): Promise<void> | ||
fromJSONSync(invertedUnitProps: InvertedUnitProps): void | ||
toJSON(standalone: boolean = false, includeSchemaVersion: boolean = false): InvertedUnitProps | Save this InvertedUnit's properties to an object for serializing to JSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItem | SchemaItemKey): boolean Static | SchemaItem | Indicates if the two SchemaItem objects are equal by comparing their respective SchemaItem.key properties. |
parseFullName(fullName: string): [string, string] Static | SchemaItem | Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings. |
Properties
Name | Type | Description | |
---|---|---|---|
_invertsUnit Protected | undefined | LazyLoadedUnit | ||
_unitSystem Protected | undefined | LazyLoadedUnitSystem | ||
invertsUnit Accessor ReadOnly | undefined | LazyLoadedUnit | ||
schemaItemType Readonly | InvertedUnit | ||
unitSystem Accessor ReadOnly | undefined | LazyLoadedUnitSystem |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_description Protected | undefined | string | SchemaItem | |
_key Protected | SchemaItemKey | SchemaItem | |
_label Protected | undefined | string | SchemaItem | |
description Accessor ReadOnly | undefined | string | SchemaItem | |
fullName Accessor ReadOnly | string | SchemaItem | |
key Accessor ReadOnly | SchemaItemKey | SchemaItem | |
label Accessor ReadOnly | undefined | string | SchemaItem | |
name Accessor ReadOnly | string | SchemaItem | |
schema Readonly | Schema | SchemaItem |
Defined in
Last Updated: 20 June, 2023