PropertyCategory Class
Beta
Extends
Methods
Name | Description | |
---|---|---|
constructor(schema: Schema, name: string): PropertyCategory | ||
fromJSON(propertyCategoryProps: PropertyCategoryProps): Promise<void> | ||
fromJSONSync(propertyCategoryProps: PropertyCategoryProps): void | ||
toJSON(standalone: boolean = false, includeSchemaVersion: boolean = false): PropertyCategoryProps | Save this PropertyCategory's properties to an object for serializing to JSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItem | SchemaItemKey): boolean Static | SchemaItem | Indicates if the two SchemaItem objects are equal by comparing their respective SchemaItem.key properties. |
parseFullName(fullName: string): [string, string] Static | SchemaItem | Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings. |
Properties
Name | Type | Description | |
---|---|---|---|
_priority Protected | number | ||
priority Accessor ReadOnly | number | ||
schemaItemType Readonly | PropertyCategory |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_description Protected | undefined | string | SchemaItem | |
_key Protected | SchemaItemKey | SchemaItem | |
_label Protected | undefined | string | SchemaItem | |
description Accessor ReadOnly | undefined | string | SchemaItem | |
fullName Accessor ReadOnly | string | SchemaItem | |
key Accessor ReadOnly | SchemaItemKey | SchemaItem | |
label Accessor ReadOnly | undefined | string | SchemaItem | |
name Accessor ReadOnly | string | SchemaItem | |
schema Readonly | Schema | SchemaItem |
Defined in
Last Updated: 20 June, 2023