Beta
Extends
Methods
Name |
Description |
|
constructor(schema: Schema, name: string): Format |
|
|
addUnit(unit: Unit | InvertedUnit, label?: string): void Protected |
Adds a Unit, or InvertedUnit, with an optional label override. |
|
fromJSON(formatProps: FormatProps): Promise<void> |
|
|
fromJSONSync(formatProps: FormatProps): void |
|
|
hasFormatTrait(formatTrait: FormatTraits): boolean |
|
|
setPrecision(precision: number): void Protected |
|
|
toJSON(standalone: boolean = false, includeSchemaVersion: boolean = false): FormatProps |
Save this Format's properties to an object for serializing to JSON. |
|
Inherited methods
Properties
Name |
Type |
Description |
|
_base Protected |
BaseFormat |
|
|
_units Protected |
undefined | [Unit | InvertedUnit, undefined | string][] |
|
|
decimalSeparator Accessor ReadOnly |
string |
|
|
formatTraits Accessor ReadOnly |
FormatTraits |
|
|
includeZero Accessor ReadOnly |
undefined | boolean |
|
|
minWidth Accessor ReadOnly |
undefined | number |
|
|
precision Accessor ReadOnly |
DecimalPrecision | FractionalPrecision |
|
|
roundFactor Accessor ReadOnly |
number |
|
|
schemaItemType Readonly |
Format |
|
|
scientificType Accessor ReadOnly |
undefined | ScientificType |
|
|
showSignOption Accessor ReadOnly |
ShowSignOption |
|
|
spacer Accessor ReadOnly |
undefined | string |
|
|
stationOffsetSize Accessor ReadOnly |
undefined | number |
|
|
stationSeparator Accessor ReadOnly |
string |
|
|
thousandSeparator Accessor ReadOnly |
string |
|
|
type Accessor ReadOnly |
FormatType |
|
|
units Accessor ReadOnly |
undefined | [Unit | InvertedUnit, undefined | string][] |
|
|
uomSeparator Accessor ReadOnly |
string |
|
|
Inherited properties
Defined in
Last Updated:
20 June, 2023